Page tree
Skip to end of metadata
Go to start of metadata

Bevor Sie mit einer neuen Installation starten, informieren Sie sich bitte hier über die notwendigen Voraussetzungen zum Betrieb der Communote Software.

Vorausgesetzt, Sie haben das technische Wissen, dann können Sie Communote auch unter Verwendung älterer Hardware oder älteren Datenbanken betreiben. Beachten Sie, dass unser Support Sie bei Problemen nur unterstützen kann, wenn Sie die empfohlenen und getesteten Systeme verwenden.

Wir sind bestrebt die gängigsten und aktuellsten Plattformen zu unterstützen, die für den Betrieb von Communote benötigt werden. Bei einem Communote Update, müssen Sie aber nicht zwangsläufig Ihren vorhandenen Anwendungs- oder Datenbankserver aktualisieren. Schauen Sie in den unten aufgeführten Listen nach, ob die Voraussetzungen der aktuellen Communote Version noch zu Ihrer Plattform passen und aktualisieren Sie falls es empfohlen wird.

Zeichenbedeutung

(tick) = unterstützt, (warning) = Unterstützung läuft aus, (error) = keine offizielle Unterstützung mehr

1. Betriebssystem

Communote kann auf einem der aufgeführten Betriebssysteme installiert werden. Eine Übersicht der unterstützen Betriebssysteme gibt es auf der offiziellen Oracle Seite: Oracle JDK 7 and JRE 7 Certified System Configurations

Betriebssystem

Windows (32-Bit oder 64-Bit)

(tick)

Linux (32-Bit oder 64-Bit)

(tick)

2. Anwendungsserver

Zum Ausführen der Communote Web-Anwendung ist der Tomcat Anwendungsserver erforderlich. Wir empfehlen den Einsatz von Tomcat 7. Der Support für den älteren Tomcat 6, wird in der nächsten Communote Version eingestellt.

Anwendungsserver
Apache Tomcat7.0.x (empfohlen)(tick)
Apache Tomcat6.0.x(warning)

Es wird empfohlen zusätzlich einen Apache HTTP Server auf dem Server zu installieren, dieser sollte folgende Voraussetzungen erfüllen:

  • Apache Version 2.2.5 oder höher, mit Modulen mod_proxy, mod_proxy_http und mod_proxy_balancer

3. Datenbank

Zum Betrieb von Communote benötigen Sie eine Datenbank. Die momentan unterstützten Datenbanksysteme sind in der nachfolgenden Tabelle aufgelistet.

Datenbanksystem
PostgreSQL9.3(tick)
MySQL5.0, 5.1(tick)
MS SQLServer2008 R2(tick)
MS SQLServer2012(tick)
Oracle11g(tick)

4. Java

Eine installierte Java Runtime Umgebung (JRE) wird zum Ausführen von Communote benötigt. Es wird empfohlen die aktuellste Version der Java Umgebung zu installieren.

Java Version
Oracle JRE/JDK1.7(tick)
Oracle JRE/JDK1.6(error)

(error) Der Support von Java 1.6 wurde mit dieser Version eingestellt. Communote kann nur noch mit Java 1.7 verwendet werden!

5. Hardware Voraussetzungen

Für den Einsatz von Communote empfehlen wir folgende Hardware einzusetzen:

  • 64-Bit System mit 2 oder mehr Prozessorkernen
  • 10 – 100 GB Festplattenspeicher (Die Größe hängt von der Verwendung Ihrer Datei-Uploads ab. Die reine Installationsgröße von Communote beträgt weniger als 1 GB.)
  • 2 GB Arbeitsspeicher


  • No labels